Operational Defect Database

BugZero found this defect 2527 days ago.

MongoDB | 367506

[SERVER-28475] The SCons minimum version is too low

Last update date:

12/6/2017

Affected products:

MongoDB Server

Affected releases:

No affected releases provided.

Fixed releases:

3.5.6

Description:

Info

I compile with SCons 2.3.6, on Ubuntu, and get this error, build/7a67446c/third_party/IntelRDFPMathLib20U1/intel_decimal128_readtest_wrapper.py failed: TypeError : %o format: a number is required, not str Compiling with buildscripts/scons.py (2.5.0) is successful.

Top User Comments

xgen-internal-githook commented on Tue, 28 Mar 2017 22:24:33 +0000: Author: {u'username': u'acmorrow', u'name': u'Andrew Morrow', u'email': u'acm@mongodb.com'} Message: SERVER-28475 Require SCons 2.5 and Python 2.7 Also, a drive by for making the search path for SCons in buildscripts/scons.py absolute, obviating the need to explicitly load the "install" tool. This is effectively a partial revert of the changes made for SERVER-28497. Branch: master https://github.com/mongodb/mongo/commit/fcb329a2f4c4db8a23ff54806ced5ef55e841d24

Additional Resources / Links

Share:

BugZero Risk Score

Coming soon

Status

Closed

Have you been affected by this bug?

cost-cta-background

Do you know how much operational outages are costing you?

Understand the cost to your business and how BugZero can help you reduce those costs.

Discussion

Login to read and write comments.

Have you ever...

had your data corrupted from a

VMware

bug?

Search:

...