Operational Defect Database

BugZero found this defect 2513 days ago.

MongoDB | 371973

[SERVER-28676] [v3.4] minor_version_tags_old_new_old.js should not use replSetStepUp command

Last update date:

12/6/2017

Affected products:

MongoDB Server

Affected releases:

3.4.3

Fixed releases:

3.4.6

Description:

Info

The test uses old versions of mongodb (3.2) that do not support replSetStepUp. Calling ReplSetTest::initiateWithAnyNodeAsPrimary instead of ReplSetTest::initiate should fix this. This is only an issue for 3.4 because master uses 3.4 as the older version which does support replSetStepUp.

Top User Comments

benety.goh commented on Wed, 14 Jun 2017 02:54:17 +0000: As of this commit, minor_version_tags_old_new_old.js no longer uses the replSetStepUp command. benety.goh commented on Fri, 19 May 2017 14:20:51 +0000: With SERVER-28100, tags.js no longer uses replSetStepUp.

Additional Resources / Links

Share:

BugZero Risk Score

Coming soon

Status

Closed

Have you been affected by this bug?

cost-cta-background

Do you know how much operational outages are costing you?

Understand the cost to your business and how BugZero can help you reduce those costs.

Discussion

Login to read and write comments.

Have you ever...

had your data corrupted from a

VMware

bug?

Search:

...