Operational Defect Database

BugZero found this defect 2440 days ago.

MongoDB | 397068

[SERVER-29798] Ensure 3.4 secondary replicates featureCompatibilityVersion document in set_feature_compatibility_version.js

Last update date:

10/30/2023

Affected products:

MongoDB Server

Affected releases:

No affected releases provided.

Fixed releases:

3.5.10

Description:

Info

Since the secondary has no votes, "majority" for the replica set equals 1, so the secondary need not receive the featureCompatibilityDocument for the setFeatureCompatibilityVersion command to succeed. In this case, the primary closes the connection to the secondary, and it spins, outputting the error message "IncompatibleServerVersion". We should give the secondary votes, so that the write is required to reach the secondary.

Top User Comments

xgen-internal-githook commented on Thu, 22 Jun 2017 21:14:29 +0000: Author: {u'username': u'tessavitabile', u'name': u'Tess Avitabile', u'email': u'tess.avitabile@mongodb.com'} Message: SERVER-29798 Ensure 3.4 secondary replicates featureCompatibilityVersion document in set_feature_compatibility_version.js Branch: master https://github.com/mongodb/mongo/commit/19fb2eca839609a0b6d34faa11daee381f4eeff4

Additional Resources / Links

Share:

BugZero Risk Score

Coming soon

Status

Closed

Have you been affected by this bug?

cost-cta-background

Do you know how much operational outages are costing you?

Understand the cost to your business and how BugZero can help you reduce those costs.

Discussion

Login to read and write comments.

Have you ever...

had your data corrupted from a

VMware

bug?

Search:

...