Operational Defect Database

BugZero found this defect 2382 days ago.

MongoDB | 416941

[SERVER-30673] get last error command should be marked doesn't requireAuth

Last update date:

10/30/2023

Affected products:

MongoDB Server

Affected releases:

No affected releases provided.

Fixed releases:

3.5.12

Description:

Info

The get last error command can cause it to attempt to process session info, which may possibly dirty up the client object with a new error (from doing auth work). Marking it ! requiresAuth will avoid that codepath

Top User Comments

xgen-internal-githook commented on Wed, 16 Aug 2017 16:31:35 +0000: Author: {'username': 'hanumantmk', 'email': 'jcarey@argv.me', 'name': 'Jason Carey'} Message: SERVER-30673 !requiresAuth for gle command The get last error command can cause it to attempt to process session info, which may possibly dirty up the client object with a new error (from doing auth work). Marking it !requiresAuth will avoid that codepath. Branch: master https://github.com/mongodb/mongo/commit/8b5b8220fa00538df41cf4f1bedbf0e0aefd71cb

Additional Resources / Links

Share:

BugZero Risk Score

Coming soon

Status

Closed

Have you been affected by this bug?

cost-cta-background

Do you know how much operational outages are costing you?

Understand the cost to your business and how BugZero can help you reduce those costs.

Discussion

Login to read and write comments.

Have you ever...

had your data corrupted from a

VMware

bug?

Search:

...