Operational Defect Database

BugZero found this defect 2796 days ago.

Veeam | kb2157

Product Update Fails With: "This installation cannot be updated automatically."

Last update date:

2/22/2024

Affected products:

Veeam Backup & Replication

Veeam ONE

Veeam Service Provider Console

Veeam Recovery Orchestrator

Veeam Cloud Connect

Affected releases:

ALL

Fixed releases:

No fixed releases provided.

Description:

Challenge

When attempting to update Veeam software, the following error occurs:

Cause

This error occurs when the update installer is corrupt, files on the disk are corrupt, or the certificates for file validation are not installed or up-to-date. The update installer checks both its own digital signature and those of the existing files to ensure their integrity before allowing the update to proceed. All product files are signed using Global Sign certificates. Some Windows installations do not contain Global Sign's root certificates authority as trusted root certificates or have non-current certificates. This issue is typically observed on servers with locked-down security settings, or servers with no internet access or latest updates installed.

Solution

Please verify that the downloaded file is not corrupted by checking its hash against the one provided by Veeam. If the hash of the downloaded file does not match the one listed on the Veeam website, redownload the file.The following PowerShell cmd may be used to get the hash of a file.

More Information

If the install error persists after verifying the file's hash and that the certificates are installed, create a support case and include all logs from: %programdata%\Veeam\Setup

Additional Resources / Links

Share:

BugZero® Risk Score

What's this?

Coming soon

Status

Solved

cost-cta-background

Do you know how much operational outages are costing you?

Understand the cost to your business and how BugZero can help you reduce those costs.

Have you ever...

had your data corrupted from a

VMware

bug?

Search:

...