Operational Defect Database

BugZero found this defect 1488 days ago.

Veeam | kb3135

Veeam Agent backup job configuration fails with "Xml node is not found. Name: [lsObjectRepository]."

Last update date:

7/6/2023

Affected products:

Veeam Agent for Microsoft Windows

Veeam Cloud Connect

Affected releases:

6.0

Fixed releases:

No fixed releases provided.

Description:

Challenge

When configuring a Veeam Agent job to target a Veeam Cloud Connect repository, at the Credentials step of the configuration wizard, the following error occurs: Failed to get Cloud Connect repositories, Failed to retrieve the list of available cloud resources from the service provider. Xml node is not found. Name: [lsObjectRepository].

Cause

This issue occurs because the tenant is running Veeam Agent for Microsoft Windows 6, which is incompatible with Veeam Backup & Replication versions older than version 12. Specifically, the tenant's version of Veeam Agent for Microsoft Windows expects information from the Cloud Connect environment about Object Storage Repositories, which was not provided when querying the Cloud Provider because the Veeam Cloud Service Provider's Cloud Connect server is not running version 12. The issue occurs with the following software configuration: The tenant runs Veeam Agent for Microsoft Windows 6 or newer. The Veeam Cloud Service Provider is running {product.title.vbr} 11a or earlier.

Solution

To resolve this issue, either: The tenant must uninstall Veeam Agent for Microsoft Windows 6 and instead use Veeam Agent for Microsoft Windows 5, which is compatible with Veeam Cloud Connect 11/11a.or The service provider can upgrade their environment to Veeam Cloud Connect 12 to support Veeam Agent for Microsoft Windows 6.

Additional Resources / Links

Share:

BugZero® Risk Score

What's this?

Coming soon

Status

Solved

cost-cta-background

Do you know how much operational outages are costing you?

Understand the cost to your business and how BugZero can help you reduce those costs.

Have you ever...

had your data corrupted from a

VMware

bug?

Search:

...