Operational Defect Database

BugZero found this defect 1383 days ago.

Veeam | kb3211

Veeam Service Provider Console v4 Patch 1 (build 4911)

Last update date:

2/22/2024

Affected products:

Veeam Service Provider Console

Affected releases:

4.0

Fixed releases:

No fixed releases provided.

Description:

Challenge

Veeam Service Provider Console v4 Patch 1.This patch is superseded by the Patch 2

Cause

Please confirm you are running version 4.0.0.4877 before installing this Patch 1. You can check this under Windows > Programs and features. After upgrading, your build will be version 4.0.0.4911.As a result of ongoing R&D effort and in response to customer feedback, this Patch 1 includes a set of bug fixes, the most significant of which are listed below:  What’s New:  Server Alarm for detecting unsupported Veeam Backup & Replication server configurations.   Enhancements:   Usage Reporting Usage reporting data for Veeam Backup & Replication servers v9.5 U4 located in time zones with more than 8 hours difference is now included in the report with the auto-approve function.  Backup reporting Reports generation performance has been improved.  Monitoring “Management agent connection” alarm is not triggered when a Cloud Connect server is rebooted.  Management Agent Authentication between management agents and Veeam Service Provider Console has been improved.  RESTful APIs v3 Date format in "/licensing/reports/" GET request has been changed to “yyyy-MM”.   Report generation parameters have been simplified for licensing/reports/ methods: report interval is used instead of report generation date.  Resolved issues:  UI "Protected computers" and "Protected VMs" widgets in the Overview tab do not account for the default RPO period of 30 days.   Filtering by company/reseller name does not work on the Failover Plans tab.  When using “Select All” checkbox on the Backup Jobs -> Computers tab, job actions are applied to all managed Agents regardless of selected filters.  Under certain conditions, the "Unrecognized Guid format" error message is displayed on the Companies tab. Under certain conditions, “Object reference not set to an instance of an object” error message is displayed on the Backup Jobs tab.  Server Under certain conditions, the Veeam Service Provider Console service fails to start.  Usage Reporting  If a company is removed from the configuration, error message “Usage data for sites <Site name> was not included in this report due to a data collection failure. Please collect usage details and report correct numbers manually in order to stay compliant with licensing rules.” is displayed in the usage report.  Usage Report generation fails if there are several Veeam Backup & Replication servers with the same installation ID.  Usage Report shows incorrect data if there are several Veeam Backup & Replication servers with the same database instance ID.  Usage Report always shows “Standard” license edition when using Veeam Backup Enterprise Manager. Monitoring “Immediate backup copy job state” alarm is triggered for deleted VMs. “Workstation/Server agent backups stored in cloud repository” alarms may be triggered incorrectly. Veeam Backup & Replication v10 CP2 installation is required. Billing and Invoicing Manually created invoices are sent to managed companies automatically, even if scheduling is disabled.  RESTful APIs v2 Under certain conditions, /v2/backupRepositories get method returns incorrect "freeSpace" data. /v2/backupRepositories get method can take a considerable amount of time for execution. /v2/failoverPlans get method fails with “Object reference not set to an instance of an object” error message. /v2/tenants/id/backupServers now returns GUID information for Veeam Backup Enteprise Manager in the query. RESTful APIs v3 Limit/offset parameters are not working correctly for /protectedWorkloads/virtualMachines get request. Windows Event Log Description for retention and database clean-up events is missing. ConnectWise Manage Plugin When using Custom Fields in ConnectWise Manage, billing synchronization fails with “Addition object is invalid” error message.  ConnectWise Automate Plugin  Under certain conditions, ConnectWise Automate plugin status is switching from  “Healthy” to “Error” state.

Solution

To install the Patch 1:  Back up the VSPC database. Execute VSPC.ApplicationServer.x64_4.0.0.4911.msp as administrator on the VSPC server, or run this cmdlet as administrator: msiexec /update c:\VSPC.ApplicationServer.x64_4.0.0.4911.msp /l*v C:\ProgramData\Veeam\Setup\Temp\VSPCApplicationServerSetup.txt Execute VSPC.WebUI.x64_4.0.0.4911.msp as administrator on the VSPC UI (IIS) server, or run this cmdlet as administrator: msiexec /update c:\VSPC.WebUI.x64_4.0.0.4911.msp /l*v C:\ProgramData\Veeam\Setup\Temp\VSPCWebUI.txt Execute VSPC.ConnectorService.x64_4.0.0.4911.msp  as administrator on the VSPC server, or run this cmdlet as administrator: msiexec /update c:\VSPC.ConnectorService.x64_4.0.0.4911.msp /l*v C:\ProgramData\Veeam\Setup\Temp\ConnectorService.txt

Additional Resources / Links

Share:

BugZero® Risk Score

What's this?

Coming soon

Status

Solved

cost-cta-background

Do you know how much operational outages are costing you?

Understand the cost to your business and how BugZero can help you reduce those costs.

Have you ever...

had your data corrupted from a

VMware

bug?

Search:

...