Operational Defect Database

BugZero found this defect 70 days ago.

Veeam | kb4541

Veeam Recovery Orchestrator Vulnerability ( CVE-2024-22021 |  CVE-2024-22022 )

Last update date:

2/6/2024

Affected products:

Veeam Recovery Orchestrator

Affected releases:

4.0

Fixed releases:

No fixed releases provided.

Description:

Issue Details

CVE-2024-22021 Vulnerability CVE-2024-22021 allows a Veeam Recovery Orchestrator user with a low privileged role (Plan Author) to retrieve plans from a Scope other than the one they are assigned to. Affected Version(s)*: Veeam Recovery Orchestrator 6 Veeam Disaster Recovery Orchestrator 5 Veeam Availability Orchestrator 4 Severity: Medium CVSS v3.1 Score: 4.5    CVE-2024-22022 Vulnerability  CVE-2024-22022 allows a Veeam Recovery Orchestrator user that has been assigned a low-privileged role to access the NTLM hash of the service account used by the Veeam Orchestrator Server Service. Affected Version(s)*: Veeam Recovery Orchestrator 6 Veeam Disaster Recovery Orchestrator 5 Veeam Availability Orchestrator 4 Severity: High CVSS v3.1 Score: 8.8   *Vulnerability testing was only performed using actively supported versions of Veeam Recovery Orchestrator.

Solution

The vulnerabilities documented in this article are already fixed in Veeam Recovery Orchestrator version 7. Customers are advised to upgrade to the latest Veeam Recovery Orchestrator version.

More Information

Veeam strongly recommends that customers use the most recent version of the software. However, we understand some environments may require additional planning and time to deploy an upgrade. In recognition of this, a patch has been developed for Veeam Recovery Orchestrator 6 that resolves the vulnerabilities discussed in this article. We encourage affected users who are unable to upgrade to Veeam Recovery Orchestrator 7 to apply this patch as soon as possible to maintain system security. Customers running Veeam Recovery Orchestrator 6 may either: Upgrade to Veeam Recovery Orchestrator 7. (Recommended)or Install the vulnerability resolution patch. (Details below) Customers running Veeam Disaster Recovery Orchestrator 5 must upgrade to Veeam Recovery Orchestrator 6, then review the options available for that version. Customers running Veeam Availability Orchestrator 4 must upgrade to Veeam Disaster Recovery Orchestrator 5 and then review the options available for that version.

Deployment Information

Requirements This patch requires Veeam Recovery Orchestrator 6 P20230419 (6.0.0.3516). To check which version is installed, switch to Administration view, then select the About section. Preparation Stop all tasks (plan execution or DataLab testing) in the Veeam Recovery Orchestrator UI. To update components successfully, you must be logged in as a non-domain local Administrator. You will require the service account password for all the components to be updated. Update Procedure On the Veeam Recovery Orchestrator server, run VDRO.Server.x64_6.0.0.3582.msp. On the server where the Veeam Recovery Orchestrator web UI is installed, run VDRO.WebUI.x64_6.0.0.3582.msp.

Download Information

The patch below was built for Veeam Recovery Orchestrator 6 P20230419 (6.0.0.3516).

Additional Resources / Links

Share:

BugZero® Risk Score

What's this?

Coming soon

Status

Solved

cost-cta-background

Do you know how much operational outages are costing you?

Understand the cost to your business and how BugZero can help you reduce those costs.

Have you ever...

had your data corrupted from a

VMware

bug?

Search:

...